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Course Outlines



• .NET Report Designers

• Report Viewer Controls

Course Outlines – Prerequisites

https://www.telerik.com/products/reporting.aspx#report-designers
https://www.telerik.com/products/reporting.aspx#report-viewers


1. Understanding the report lifecycle.

2. Standalone report designer.

3. Using reports in applications.

4. Creating the demo report (Page Header, Table, Chart, and Page Footer).

5. Report structure.

6. Data source components.

7. Adding interactivity to reports.

Course Outlines – Topics covered



Please bring your own Laptop with minimum spec.:

• CPU 2.0 GHz

• 64-bit architecture

• 4 or more CPUs/cores

• At least 4 GB of memory/RAM

• At least 25 GB of disk space

• Windows 10, 8.1

Install program to your laptop with the following:

• Telerik Standalone Report Designer v.14.1 (Download)

Course Outlines – Tools

https://docs.telerik.com/reporting/installation-system-requirements#installing-telerik-reporting
https://atlasx.cdg.co.th/share/telerik%20reporting/trial/Telerik_Reporting_R2_2020_SP1_14_1_20_618_TRIAL.zip


Introduction



Introduction – Reporting solution

Web and Desktop ApplicationsComplete .NET Reporting Solution



Introduction – Supports

• ASP.NET Core

• Blazor

• ASP.NET MVC

• ASP.NET Web Forms

• HTML5/JS

• Angular

• React

• Vue

• WPF
• WinForms



Visual Studio Report 
Designer

Developer-centric WYSIWYG 
report generation

Standalone Desktop 
Report Designer

Desktop based WYSIWYG 
report generation

Web Report Designer         
.

Web-based WYSIWYG report 
generation

Introduction – .NET Report Designers



Introduction – Progress Telerik Reporting

• Report Viewer Controls - Create Once, 

Deliver Everywhere

• Bring Interactive Reports to Your Users

• Filter and Sort Data at Run-Time

• Export to 15-Plus Formats

• Print Reports

• Report Viewer Themes



Download & Install



Download Trial

• https://atlasx.cdg.co.th/share/telerik 
reporting/trial/Telerik_Reporting_R2_2020_SP1_14_1_20_618_TRIAL.zip

Install

• https://docs.telerik.com/reporting/installation-system-requirements#installing-
telerik-reporting

Download & Install

https://atlasx.cdg.co.th/share/telerik%20reporting/trial/Telerik_Reporting_R2_2020_SP1_14_1_20_618_TRIAL.zip
https://docs.telerik.com/reporting/installation-system-requirements#installing-telerik-reporting


Report Lifecycle



Report Lifecycle



Report Lifecycle – Defining the report

Depending on the report designer where you 

define the report.

A .trdx or .trdp XML file for Standalone Report 

Designer.

The XML can be stored as an XML definition 

and resources that are packaged in a .zip file 
(TRDP), in a plain XML format (TRDX).



Report Lifecycle – Processing the report definition

• Performing all grouping, sorting, 

and filtering calculations.

• Evaluating all expressions in the 

report definition except page 

header and footer.

• Binding data sources.
• Producing a processing report.



Report Lifecycle – Rendering

• Passing to PDF, HTML, CSV, and 

other.

• If the rendering format supports 

paging, the processing report is 

paginated.

• Evaluating the expressions in the 

page header and footer sections for 

every page.

• Rendering the report to a report 
document.



Report Lifecycle – Implications

• Header, footer, group header, and group footer 
report sections−In expressions, use the data fields 
together with aggregate functions. By default, if an 
expression specifies a data field without a specified 
aggregate function, the report will use the First() 
aggregate function which returns the first record of 
the data source for the specified data field.

• Detail report sections−Expressions can contain data 
fields, functions,  and, except for PageNumber and 
PageCount, all global objects.

• Page header and footer report sections−Expressions 
are evaluated on a later stage in the report lifecycle. 
The paging of the report is specific for the selected 
rendering format. While data binding occurs during 
the processing of the report, the paging of the 
report occurs during the rendering of the report. 
This means that expressions in the page and footer 
sections cannot include data fields or aggregate 
functions. The PageNumber and PageCount global 
objects are available only in these sections.



Standalone Report 
Designer



Standalone Report Designer

Visual Studio 
is not required

Reports are processed

on the client machine



Standalone Report Designer

View tabRulers

Report Sections

Component Tray

View Mode Buttons



Show/hide the snap grid Show/Hide Dimensions Change the alignment of 
an element

Standalone Report Designer



Standalone Report Designer – Export Report Template



Telerik.Reporting.Xml.XmlSerializerExcepion: An error has occurred during xml 
serialization. The xml serializer cannot resolve type with name: Report.

Solution

• Find the data schema (XML version).

• See – How to: Identify the report definition schema version

• Replace the current schema for your Telerik Reporting version.

• See – XML Schema Versioning

• Trying to open.

Standalone Report Designer – Problems

When you try to open the report, it throws the following error:

https://docs.telerik.com/reporting/upgrading-xml-report-definition-versioning#how-to-identify-the-report-definition-schema-version
https://docs.telerik.com/reporting/upgrading-xml-report-definition-versioning#xml-schema-versioning


Using Reports in 
AtlasX Web 

Service



Using Reports – Add Service



Using Reports – ReportsController



Using Reports – View Template



Using Reports – Preview Report



Report Structure



Report Structure

Page Header • Printed at the top of every page.
• Repeat the report title on every page.

Table of 
Contents (TOC)

• Provides a set of navigational links to report items.
• Displays the page numbers where they can be found.

Report Header • Printed just once, at the beginning of the report.
• The Report Header will be rendered after Page Header.

Group Header • Printed at the beginning of each new group of records.
• Use the group header to print the group name.

Detail • Printed once for every row in the data source.

• Place the report items that constitute the main body of the 
report.

Group Footer • Printed at the end of each group of records.

• Use a group footer to print summary information for a 
group.

Report Footer • Printed just once, at the end of the report.
• The Report Footer will be rendered before Page Footer.

Page Footer • Printed at the end of every page.

• Use a page footer to print page numbers or per-page 
information.



Table

Report Structure

• Use a table item to display 
detail data, organize the 
data in row groups, or both.

• The Table contains three 
columns with a table 
header row and a details 
row for data.



CrossTab

Report Structure

• Use a CrossTab template to 
display aggregated data 
summaries, grouped in 
rows and columns.

• The number of rows and 
columns for groups is 
determined by the number 
of unique values for each 
row and column groups.



List

Report Structure

• Use a list item to create a 
free-form layout.

• You are not limited to a grid 
layout, but can place fields 
freely inside the list.



Report Structure – Graph : Cartesian coordinate system



Report Structure – Graph : Polar coordinate system



TextBox

Report Structure

• Used to display text on a 
report.

• Every cell in a Table or 
CrossTab also contains a 
TextBox

• The expressions in a 
TextBox can contain literal 
text, point to a database 
field or calculate data.



SubReport

Report Structure – SubReport

• Display one report within 
another report.

• The screenshot shows a 
SubReport report item at 
design-time.

• Pass parameters to 
SubReports using the Edit 
Parameters collection.



PictureBox

Report Structure – PictureBox

• Support binary image data, 
a URI that points to an 
image file, or a string 
representing a Base64-
encoded image.

• The clipping and 
positioning of an image in 
the display area of a 
PictureBox item is 
controlled by its Sizing 
property.



Panel

Report Structure – Panel

• The Panel report item is not 
associated with data and is 
used as a container for 
other items, usually to 
group/separate multiple 
report items by some 
criteria.



Barcode

Report Structure – Barcode

• The Barcode item is used 
for automatic barcode 
generation directly from a 
numeric or character data.



Creating the Demo 
Report



Demo Report – Create a new report

1. Navigate to the installation folder. For 

example, C:\Program 

Files(x86)\Progress\Telerik Reporting R1 

2020\Report Designer.

2. Run the Standalone Designer 

(Telerik.ReportDesigner.exe).

3. Click New > Blank Report and choose a 
destination for saving the report.



Demo Report – Setting the Header and the Title

Setting the Header and the Title

1. Click pageHeaderSection.

2. From the bar, select Insert to add the 

title. Click TextBox to automatically place 

the TextBox in the header.

3. From the Properties grid, select the Font

option to change the font of the title.

4. Change the pageHeaderSection style.

Adding the Logo

1. Go to Insert and select PictureBox.

2. Include the desired picture through the 

Value property. If you need to adjust the 

size of the picture, use the Sizing

property.



Demo Report – Populating the Table with Data

Adding the WebServiceDatasource

1. Select Data > Web Service Data Source.

2. In Use Web Service Request tab.

• Service URL: 

https://atlasx.cdg.co.th/axws-

demo/api/appdata

• Method: Get

• Data Selector: data

3. Click Next.

https://atlasx.cdg.co.th/axws-demo/api/appdata


Demo Report – Populating the Table with Data (2)

Adding the WebServiceDatasource

4. Click New and input the following 

parameters:
• APP_DATA_SOURCE = SQLServer

• APP_DATA_PROCEDURE = RPT_PROVINCE_Q

5. Click Next.

6. Click Download to preview data or Finish 

to close wizard.

7. From the grid with the properties, 

change the name of the data source to 

PROVINCE so you can later refer it and 

render its data in the report.



Demo Report – Populating the Table with Data (3)

Creating the Table

1. Click the datailSection.

2. From the bar, select Insert.

3. Select Table > Table Wizard > PROVINCE

data source.

4. On the screen that loads, mark all 

columns and drag them to the Table 

Columns. Click Next.

5. From the window that opens, select a 

predefined style for your table.

6. Click Next and Finish.

7. Apply some Styling.

8. Add the title of the table.



Demo Report – Creating the Graph

1. To reveal the report header, right-click 

outside the report and select Report 

Header.

2. Select Insert > Pie > PROVINCE.

3. Drag PROV_NAMT to Series.

4. Drag TOTAL to Values.



Demo Report – Creating the Graph (2)

5. From the Group Explorer, click Filter and 

set the following parameters:

• Expression: =Sum(Fields.TOTAL)

• Operator: Top N

• Value: =5

6. From the Group Explorer, click Sorting

and set the following parameters:

• Expression: =Sum(Fields.TOTAL)

• Direction: DESC

7. From the Properties grid, select the 

Color Palette option to set specific colors 

for each bar series.

8. Add the title of the graph.



Demo Report – Setting the Page Footer

1. Click pageFooterSection and add a 

Textbox which will display the current 

date and time.

2. Set the Value property Expression to the 

Date and Time function =Now().

3. From the bar, select Insert > Barcode to 

add a Barcode item.

4. Set the Value property Encoder to the 

QRCode.

5. Place the https://atlasx.cdg.co.th link in 

the Value field of the Barcode.

6. Set the top border of the footer.



Data Source Components



Data Source Components

Enables you to work with Microsoft SQL 

Server, MySQL, Oracle, OLE DB, ODBC, 

Postgres, MS Access databases, and any other 

database with available ADO.NET provider.

Enables you to work with CSV data -
embedded or from a local file.

Enables you to work with data 
located on a service in JSON format.

Enables you to work with business 

objects or other classes and 

allows you to create reports that 
display data from the middle-tier.

Enables you to work with data in JSON 
format - embedded or from a local file.



Adding Interactivity



Adding Interactivity – Sorting Table Details

1. Select the table "จังหวัด" text box located 

in column header to which we want to 

add an interactive sorting button.

2. From Properties window open the 

Actions editor.

3. Select Sorting option.

4. Click Edit sort targets button to open 

Edit Sorting Action targets editor.

5. Click New to add a new target.

6. Select the same Table as target from the 

drop down.

7. Click OK.

8. In Sort expressions drop-down select the 

field Fields.PROV_NAMT.

9. Click OK.



Adding Interactivity – Drilldown Report Action

1. Create  the Nostra District 

Population.trdx report template 

(Duplicate the province report).

2. Right-click outside the report. Select 

Report Parameters to add the Report 

Parameters of the province.

3. Set PROVINCE as in the right picture:

4. Add a new  Web Service Data Source 

and and input the following parameters:
• APP_DATA_SOURCE = SQLServer

• APP_DATA_PROCEDURE = RPT_DISTRICT_Q

• PROV_CODE = The PROVINCE parameter

5. Rename the data source to DISTRICT.



Adding Interactivity – Drilldown Report Action (2)

6. Select the table and switch data source 

from PROVINCE to DISTRICT.

7. Update the title header and detail 

expression table.

8. Back to The Province report. Select the 
table "=Fields.PROV_NAMT" text box 

located in column detail to which we 

want to add an interactive drilldown 

button.

9. From Properties window open the 

Actions editor.

10. Select Navigate to Report option.

11. Setting up the report source as in the 

following picture:



Adding Interactivity – Drilldown Report Action (3)



Q&A



THANK YOU
For Your Attention

29 June 2020

Prepared by GIS Co., Ltd.


